Streamlit Cloud Streamlit version not updating

Hi there.

I have an app deployed to Streamlit Cloud, the streamlit version on my machine is 1.25.0. I’ve specified this in my requirements.txt file as follows:


However, streamlit still runs on version 1.8.1 on the cloud.

Things I’ve tried:

  • The requirements.txt file reflects the latest changes on the main branch in my GitHub repository.
  • I’ve used st.write to display the streamlit version on the sidebar (st.version).
  • Manually rebooted the app on the cloud.

Is there something I’m missing? Why is my cloud version still so far behind?

I deployed an app with exactly the same requirements.txt and streamlit==1.25.0 was installed as expected (checked by writing st.__version__).

1 Like

Try re-dploying the app from a different branch (create one for testing if you don’t have one yet) and select a new python version.
Check the results and if things work out, I suggest you take down the old deployement and start a new from the main branch.

1 Like

Thank you, this solved it!

I did have a testing branch, redeploying it from there seems to have fixed the problem. I remade the app for the main branch too, and I can confirm it works as well. It turns out that the streamlit version remains fixed at the version it was initially deployed at, regardless of the updates to the requirements.txt.

Edit: Added initially

Hey everyone!
I have the same problem. Streamlit Cloud seems to not running the “install requirements …” command after I change the requirements.txt. Rebooting the app doesn’t help. Yesterday everything worked as expected.

I would like to avoid deleting and creating a new a app as there are already quit many registered users in my app and I don’t like to force them to reregister

@Niklas_Kobelev Can’t you backup your userbase or migrate it so they just have to log-in only?

If not, try breaking your app:

  1. Delete your requirements.txt, commit, push, deploy then reboot just in case.
  2. Add the new requirements.txt with the new version. push and deploy, and reboot (again, just in case).

There are some odd anomalies going on on the servers as I can read on the forum users are complaining about, might be part of the problem and can be fixed from Streamlit’s team side maybe.
In doubt, open a new issue/question with specifics to your use-case (the registered users part) so it’s not a total duplicate.

Thank You for the fast response! I can’t try it out today unfortunately. I will come back with an update tomorrow.

Restarting or resuming applications is not working on Community Cloud. The team has identified the issue and implemented a fix and we are monitoring the results.

Hey everyone, this issue is now resolved – please let us know if you continue to see this problem.


It seems to be solved, the dependencies are installed as expected. Thank You and Your team for the fast fix!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.