Streamlit Sign-in redirects to a random website

Hi everyone.

I just noticed today that when I click on Sign-in on Streamlit cloud page, it redirects me to random website that goes with the name: Rogers Self-serve. I have attached a screen-record below so that it will be helpful for you to resolve this. The Sign-up function works though.

Screen-record video link: Streamlit Sign in issue

Hi @Abinashbunty, and welcome to our community! :raised_hands:

Here are 2 things that may be worth trying:

  • Clear your browser’s cache and cookies. Sometimes, a corrupt cache can cause odd behaviors with websites.
  • Some browser extensions, especially those related to ad-blocking or VPNs, can interfere. Disable extensions one by one to see if one of them is causing the problem.

Let us know if these don’t change that problematic redirect, and we’ll investigate.

Best wishes,
Charly

Thank you @Charly_Wargnier

I tried both the options that you suggested, but it still didn’t work.

Hi All,

Confirming this is an issue with a redirect to Rogers Self-Serve and is not random. I tried clearing the cache and that did not work (I did not try extensions). I was able oddly to get to the streamlit page from the Rogers Self-Serve using the back button. However, I think this issue merits further investigation. A concern arising from this, which I suspect may be unwarranted in practice, is that when granting Streamlit access rights to Github repos something else may be going on. It would therefore be helpful if this issue could be further clarified on the streamlit side. Many thanks.

I tried using the back button but it didn’t work. So it definitely needs further investigation so that streamlit cloud can be used.

Thanks, @Abinashbunty.

Looping in @Ted_Ricks, as he might be aware of such redirect issues.

Best,
Charly