Streamlit working on web browser (not mobile)

Hello everyone!

Amazing tool! Love what you guys did.

After building and deploying my app to https://playground-ml.herokuapp.com/ I came to notice that it doesn’t open on mobile browsers (specifically IPhone when using Safari and Chrome) : when you hit the link, you’re faced with a blank page (not even an error message)

Could this be related to Heroku?

It’s hard to debug on mobile. On desktop, everything works fine. Has anyone faced this issue?

Thanks for your help.

1 Like

Hello @ahmedbesbes, welcome to the community! And what a nice app you have delpoyed there :slight_smile:

On my side your link works perfectly on iPhone Chrome and Safari though, I’ve been able to change dataset and play with the sidebar parameters. Did you change anything in between?

Cheers,
Fanilo

Great app!

Hello @ahmedbesbes ,

I had the same issue. My app worked on web browser, on some mobiles but not on all mobiles.
I solved that by taking a previous version of Streamlit (0.74.0 in my case).

Hope it will help you.

1 Like

Hi All,

Even my application was not launching on iPhone earlier then I tried with Streamlit (0.74.0), it worked for few days and it’s not working again.

Application loads on iPhone and it gives me Connection error - connection timed out.

https://nlpapp-st.herokuapp.com/

Heroku logs:

2021-04-16T14:32:33.298358+00:00 heroku[router]: at=info method=GET path="/healthz" host=nlpapp-st.herokuapp.com request_id=d297e2f4-f86a-41ab-91cb-d0fcdd448edf fwd=“106.217.100.148” dyno=web.1 connect=1ms service=7ms status=304 bytes=292 protocol=https
2021-04-16T14:32:34.725040+00:00 heroku[router]: at=info method=GET path="/healthz" host=nlpapp-st.herokuapp.com request_id=1aedbc1b-5568-42be-a750-d56d60967f67 fwd=“106.217.100.148” dyno=web.1 connect=1ms service=4ms status=304 bytes=292 protocol=https
2021-04-16T14:32:36.077757+00:00 heroku[router]: at=info method=GET path="/healthz" host=nlpapp-st.herokuapp.com request_id=01b39f39-b24f-4145-9abd-274a98231e18 fwd=“106.217.100.148” dyno=web.1 connect=1ms service=4ms status=304 bytes=292 protocol=https
2021-04-16T14:32:37.409499+00:00 heroku[router]: at=info method=GET path="/healthz" host=nlpapp-st.herokuapp.com request_id=3d699207-9606-4ba7-b5e0-28e0e6c2c439 fwd=“106.217.100.148” dyno=web.1 connect=1ms service=4ms status=304 bytes=292 protocol=https
2021-04-16T14:32:37.643845+00:00 heroku[router]: at=info method=GET path="/stream" host=nlpapp-st.herokuapp.com request_id=d436ec30-37e3-4fc2-82c4-b5195c21935c fwd=“106.217.100.148” dyno=web.1 connect=1ms service=7ms status=101 bytes=298 protocol=https

Could you please help me on this issue?

Thanks