Try to get apps up doesn't work

When trying to get my apps back up, they stuck and showing Initializing Java applet…
Earlier the apps where booting without any problems.

Here’s an example for one of my Apps

Link to the app:

Can you share the repository for your app?

Here’s the code: GitHub - tobiarnold/CO2-per-Country

Thanks! I don’t see any obvious issues – could you try deleting and re-deploying your app?

Actually i also get problems when loggin into my streamlit account since a couple of hours.
So I’m currently not able to reboot the app.
After Login i get the following error:

I contacted the support but still waiting for an answer

Hey @saibot90, can you DM me the email address you’re using to log in?

1 Like

I don’t see any obvious issues either.
Just two improvements:

  • use plotly in your requirements.txt file, instead of plotly-express
  • load your data directly from the filesystem instead via https:
    df = pd.read_csv("data.csv")
    df2 = pd.read_csv("data_graph.csv")
1 Like

After Login in my Account worked again, I was able to reboot the App and now it works :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.