Unable to deploy example app using conda (environment.yml)

My experience so far with deploying Streamit apps is that they gnerally work fine with packages specified via requirements.txt.

However I have not had any success via the conda (environment.yml) path :frowning:

So I tried a simpler experiment today with example from here: GitHub - streamlit/streamlit-example: Example Streamlit app that you can fork to test out share.streamlit.io

I deployed this (simple) example without any modifications; then I tried turning the requirements.txt off and creating an “equivalent” conda environment.yml file. Alas the app does not deploy :frowning:

My public forked repo is here:

So I did one more test - I realised I asked conda for a 3.8.x version of Python in the environment.yml (I think the default is Python 3.7 in Streamlit Cloud) – so I changed this in the deployment Advanced Settings… however this failed as well.

I am trying to remove Python & pip as requirements from environment.yml to see if this helps. Alas this also failed.

Would appreciate any thoughts you have on this as we typically use conda (mamba) to manage our Python environments.

4 Likes

I am facing the exact same issue @mjboothaus . Any workaround for this?

Hi -

I didn’t get any resolution on this - even though the documentation says conda is supported — I ended up going with using requirements.txt and have moved away from using conda (just venv & pip install instead).

I ended up doing the same

I had to do the same. All I did was replace the environment.yml with a requirements.txt file

Really surprised this hasn’t been addressed :slight_smile:

Yeah, I’ve had to do a full switch to pip. A pain when using geopandas.

Same here, would love to use conda!