My app was running fine until recently and now gives error as I required to change some dependency versions. The app will work fine if I can install numpy version 1.20. I use requirements.txt and have numpy==1.20.0 line. When deploying the app, it first downloads the correct version, but then uninstalls it and downloads the latest version (1.24.3).
Thank you for sharing your question with the community!
Your post is missing a code snippet and a link to your app’s GitHub repo. Please check out our guidelines on how to post an effective question here and update your post to help the community answer your question.
Thank you, @mathcatsand, for your response and solution. I would like to add an additional tip for those seeking a solution: make sure to include “streamlit” as the first line in your requirements file. I am not sure if order of packages in requirements.txt is important but in my specific case, having “streamlit” listed later in the file did not yield the desired outcome.
Strictly necessary cookies
These cookies are necessary for the website to function and cannot be switched off. They are usually only set in response to actions made by you which amount to a request for services, such as setting your privacy preferences, logging in or filling in forms.
These cookies allow us to count visits and traffic sources so we can measure and improve the performance of our site. They help us understand how visitors move around the site and which pages are most frequently visited.
These cookies are used to record your choices and settings, maintain your preferences over time and recognize you when you return to our website. These cookies help us to personalize our content for you and remember your preferences.
These cookies may be deployed to our site by our advertising partners to build a profile of your interest and provide you with content that is relevant to you, including showing you relevant ads on other websites.