Unable to install streamlit with conda

Hi everyone,
I am unable to install streamlit.
I use conda, and pip install streamlit gives me this:

ERROR: pydeck 0.3.0 has requirement jinja2>=2.10.1, but you’ll have jinja2 2.9.6 which is incompatible.
ERROR: pydeck 0.3.0 has requirement numpy>=1.16.4, but you’ll have numpy 1.16.1 which is incompatible.
Installing collected packages: validators, tornado, click, ipykernel, widgetsnbextension, ipywidgets, pydeck, base58, streamlit
Attempting uninstall: tornado
Found existing installation: tornado 4.5.1
ERROR: Cannot uninstall ‘tornado’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

I’m with Python 3.6, and my current Jupyter and Spyder (3.1.4) environments installed via Anaconda are perfectly fine with me, and I don’t want to take a risk to disturb anything by some packages’ incompatibilites.

Would anyone help please ?
Thanks !

I create a separate Anaconda environment for Streamlit with just the python version specified. Then I install everything else into that environment with pip and requirements.txt. This minimizes any conflicts. You may have to force some versions in the requirements.txt, depends on what other packages your application needs.

Hello @AZlearn and welcome to the forums !

As @knorthover pointed out, it’s better to keep your base conda environment fresh and create a new environment for Streamlit and other libraries.

Could you try to follow this guideline for creating a new conda environment with Streamlit inside ? Do tell us if you think some steps need clarification !

Thank you for your help. I have it installed now.
Thanks again

Thanks so much! I didn’t know this Environment feature in conda. It works, I have my Streamlit installed now
Thanks again

Unfortunately, after the installallation successfully completed, I ran into these issues:

Pb1: streamlit hello does open a streamlit page on my browser, but a click on demos doesn’t launch them

Pb2: “streamlit run myscript.py” says that a page is being opened on my browser, gives a local address and a url address, but nothing happens on my browser

Then I restarted my computer, hoping that things are getting better. But, it’s worse, I got this on the terminal :

Pb 3: (Streamlit) C:\Users\user>streamlit hello
C:\Users\user\Anaconda3\python.exe: No module named streamlit

It seems strange, since Streamlit environment has been selected in Anaconda navigator. And it didn’t say it the first time immediately after installation

What shoud I do please ?

Thanks in advance, and have a nice day


Hmmmm looks like things mixed up in the install…
For example :

Pb 3: (Streamlit) C:\Users\user>streamlit hello
C:\Users\user\Anaconda3\python.exe: No module named streamlit

I can see with (Streamlit) that you are indeed in your new conda environment, but it still calls base python C:\Users\user\Anaconda3\python.exe instead of the python in the new environment (should be something like C:\Users\user\Anaconda3\envs\Streamlit\Python.exe).

since you have a terminal to your conda environment now, could you run the following commands in your conda terminal in the Streamlit environment ?

$ echo $PATH #or %PATH% on Windows # should check if C:\Users\user\Anaconda3\envs\Streamlit\Python.exe is somewhere at the start of the path
$ pip list # should check if Streamlit is indeed installed
$ which python  # should check if using base Python or Python in Streamlit env
$ which streamlit # for later

I think I saw something similar in the forums, lemme look for it in the meantime !

Thanks for your quick reply.

echo and which didn’t work for me, so I tried the other things you pointed out

It seems that Streamlit was really installed. Here :
17/04/2020 11:57 .
17/04/2020 11:57 …
17/04/2020 08:59 Streamlit
(base) C:\Users\user\Anaconda3\envs\Streamlit>

There are 2 pip, one here:
(base) C:\Users\user\Anaconda3\Scripts>
this pip list doesn’t find streamlit
SQLAlchemy 1.1.9
statsmodels 0.8.0
sympy 1.0

the other pip.exe is here:
(base) C:\Users\user\Anaconda3\envs\Streamlit\Scripts>
17/04/2020 06:59 106 356 pasteurize.exe
17/04/2020 06:51 214 pip-script.py
15/06/2018 21:02 40 960 pip.exe
05/03/2020 12:20 57 pydoc-script.py
04/03/2020 01:22 40 960 pydoc.exe
but pip list in this directory gives this:
(base) C:\Users\user\Anaconda3\envs\Streamlit\Scripts>pip list
Unable to create process using ‘C:\Users\user\Anaconda3\envs\Streamlit\python.exe C:\Users\user\Anaconda3\envs\Streamlit\Scripts\pip-script.py list’

Thank you for your help.