URL redirect masked (iframe) not working


I have deployed an app on Streamlit Community Cloud and tried to mask the Streamlit URL - with my own URL that I redirect to the Streamlit URL.

It works fine with “permanent redirect” or “unmasked redirect”, but it does not work with “masked URL”.

Is it possible to use “masked redirect” in Streamlit Cloud?

Thank you,


I played around a little bit with my own DNS. I can’t get away with a CNAME record because of the security certificate. Other variations haven’t played out well yet.

I am able to mask a site by hosting a simple, single page:


    <title>Valmetrics Dash App</title>

    <frame src='https://dash-valmx.streamlit.app/?embed=True'>


The url will remain static on a multipage app, hiding the page urls just fyi. If you can host these couple of lines somewhere that you can control the url more concretely, that would be one solution. Maybe create a page on GitHub? I haven’t hosted any websites on GitHub yet, but it looks like the documentation has options for configuring the url. Azure also lets you host a static web page for free (if you pay for the associated storage) so that’s another option if you happen to already have storage there. I’m sure it’s similar for other cloud providers as well. :slight_smile:

1 Like

Thank you, @mathcatsand. I understand this solution and will try it. However, I would also be interested to know why it is not possible to do “masked URL forwarding”. Is it because Streamlit does not allow this, or is there another reason?

I am not a front end expert, but I imagine it all has to do with the security settings like the certificate. You can try to redirect to https://dash-valmx.streamlit.app/?embed=True with the embedding keyword like in the frame example to see if that behaves any better.

Thanks. It is working now (with “?embed=True”) - although there is still a “connection is not secure” message on the browser.