Version 1.17.0

Notable Changes

  • :magic_wand: @st.experimental_singleton supports an optional validate parameter that accepts a validation function for cached data and is called each time the cached value is accessed.
  • :floppy_disk: @st.experimental_memo’s persist parameter can also accept booleans.

Other Changes

  • :pager: Multipage apps exclude from the page selector (#5890).
  • :triangular_ruler: The iframes of embedded apps have the ability to dynamically resize their height (#5894).
  • :lady_beetle: Bug fix: thumb values of range sliders respect the container width (#5913).
  • :beetle: Bug fix: all examples in docstrings of Streamlit commands contain relevant imports to make them reproducible (#5877).

It seems that version 1.17.0 introduced some braking changes in spacing between paragraphs?

Version 1.15.1:

Version 1.17.0

Hi @TomJohn , could you possibly create a bug report for this? Someone on our team is usually look at github issues but not the forum so sometimes these bug reports on the forum get lost!

SWE at Streamlit / Snowflake

1 Like

Hi @willhuang thanks for answer. Github issue created here: Changes in padding of header paragraphs in 1.17.0 · Issue #6048 · streamlit/streamlit · GitHub

1 Like

Hi, after updating streamlit to the latest version I got an error while importing streamlit:

AttributeError: module '' has no attribute 'Icicle'

Can you tell me what is going on?


That is not fair. It is common for a traceback to have a dozen lines, often more, and you expect us to guess based on just the last one.

I will take my chances anyway: your plotly is too old, upgrading to a more recent version might fix the issue.

1 Like

I am sorry for that. This issue happens when I have installed streamlit 1.17.0, I found same problem on StackOverflow:, when I downgraded streamlit it is working fine again.

Here is the error Traceback


(DataSci) D:\SciDirectScraper>streamlit run
Traceback (most recent call last):
    from streamlit.delta_generator import DeltaGenerator as _DeltaGenerator
  File "D:\DataSci\lib\site-packages\streamlit\", line 75, in <module>
    from streamlit.elements.plotly_chart import PlotlyMixin
  File "D:\DataSci\lib\site-packages\streamlit\elements\", line 41, in <module>
    import streamlit.elements.lib.streamlit_plotly_theme
  File "D:\DataSci\lib\site-packages\streamlit\elements\lib\", line 116, in <module>"white"))
  File "D:\DataSci\lib\site-packages\_plotly_utils\", line 41, in _getattr_
    name=import_name, __name__=parent_name
AttributeError: module '' has no attribute 'Icicle'

Did you try upgrading plotly?


I am also getting same error after installing stramlit-1.17.0 and upgrading plotly does not resolve the issue.
Will have to go with older version of streamlit I guess to make it work as of now.

I just tried upgrading both. Streamlit to 1.17 and Plotly to 5.13. it worked for me! Thanks! @Shweta_Sahu


Hi @czubert @Shweta_Sahu :wave:

As @Goyo rightly pointed out, the issue is with your plotly version being too old. Icicle charts were released in Plotly 5.0.0, two years ago in June.

You need to install a version of Plotly >= 5.0.0. Here’s a screenshot of my Terminal when I have an older version and newer version that supports Icicle charts. It is clear the issue stems from older Plotly versions:


Hi Shweta, it would be a good idea to upgrade. Can you give us some more information as to what’s going on for plotly not working? I would guess it has to deal with your dev environment.
Can you explain to me your dev environment so that we can get that resolved?