You are using pip version 22.0.3; however, version 22.0.4 is available. You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command

how to solve this

Hi @cousins, welcome to the community!! :partying_face: :wave:

Fortunately, there is nothing to solve. What you are seeing is a benign log message/warning by pip, which you can feel free to ignore.

Happy Streamlit-ing! :balloon:
Snehan

1 Like

Today this message keeps popping out when rebooting app

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
streamlit 0.85.1 requires click<8.0,>=7.0, but you have click 8.0.0 which is incompatible.
Successfully installed protobuf-3.20.1
WARNING: You are using pip version 22.0.3; however, version 22.1.2 is available.

You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.

Hi @jcmachicao -

The pip message is still benign, and not what the logs are really trying to reflect to you:

streamlit 0.85.1 requires click<8.0,>=7.0, but you have click 8.0.0 which is incompatible.

Do you specifically need to use streamlit 0.85.1? That’s around a year old, so you’re missing new features, bug updates and performance upgrades. If you actually do need that version, then you need to pin the click package to conform between <8.0,>=7.0

Best,
Randy

1 Like