Your app is in the oven!


I get the “Your app is in the oven” message on my uploaded app on the streamlit sharing:

The message just does not go away and I also don’t get any logs on what the issue is.

Do you have any ideas?

The app is running perfectly on my laptop (locally).

Hi @hadisotudeh , can you share github link to your repo, I’ll have a look at it.

Sure, here is the link:

I guess that because your repo contains 2 requirements.txt files, it was stuck in a loop while deploying. I tried deploying to streamlit sharing after deleting the subfolder fifa-stats-crawler-master it worked for me. Try deleting that sub-folder or just rename that requirements.txt in the sub-folder to a different name in your github repo and redeploy. Hope this helps.

1 Like

Hey @hadisotudeh,

Welcome to our Streamlit Community! :partying_face: :partying_face: :partying_face: :tada:

Let us know if the solution that @sree369nidhi has found works, and I can mark it as solved!

Happy Streamlit-ing!

Hi @Marisa_Smith,

Yes, I followed the recommendation @sree369nidhi had and deleted that subfolder.
Still, I have the same issue and “Your app is in the oven” is there!

Any idea?


Take a look at this @hadisotudeh i was able to successfully deploy the app

Look at the repo,

weird, I updated the structure of my git repo as yours and followed the steps again and again the same error. Can it be there is something wrong with my account?

Hmm… Thats strange… As long as you have received the invitation to Streamlit Sharing it should work.

I was able to deploy your app actually after forking it to my own github!

I didn’t make any changes to the folder structure that you had after you deleted the fifa-stats-crawler-master. Not sure what is happening here. Can you put a screen shot of the settings as your deploy your app?

What is your repo, branch and main file path?

Here is the screenshot:

I think there is something going wrong with my account. Maybe if you remove my account and send me a new invitation to join streamlit sharing that can solve the issue.

ok, that looks exactly like what I used to successfully deploy so this an odd one! :thinking:

I am looping @tc1 in as he has the power to send out sharing invites! :mechanical_arm: :space_invader:

In the mean time I will send this along to our engineering team to check out. We want the Streamlit Sharing process to be simple and quick, so I want to send this along to make sure that this is not something that others are encountering.

Will get back to you when I know more,

1 Like

Hey @hadisotudeh,

We have done some investigating on our end, made a couple adjustments in our database and would like you to retry deploying your app now.

Hopefully we got the bug! :crossed_fingers: :beetle:

Hello @Marisa_Smith,

Yes, it is fixed now. Up and running on

Thanks for the support.

1 Like