Your app is in the oven for long time

Hello,

I get the “Your app is in the oven” message on my uploaded app on the streamlit sharing:

https://bruninhanic-appmercadofinanceiro-appstreamlitapp-joiw8y.streamlitapp.com/

The message just does not go away and I also don’t get any logs on what the issue is.

Do you have any ideas?

The app is running perfectly on my desktop (locally).

I alread removed from requirements streamlit and windows packages: Cython and pywin.

Thanks!

Bruna.

Hey @bruninhanic!

Welcome to our forum :slight_smile: I confirm I also see your app still booting!
Asked our engineers what could be happening.

Is your code accessible? Or your requirements at least? Sometimes requirements have so many dependencies that it can take a while to solve them!

1 Like

Hey, @arnaud!

Thanks!

I will publish temporarily: https://github.com/bruninhanic/appMercadoFinanceiro

Link to requirements: https://github.com/bruninhanic/appMercadoFinanceiro/blob/master/app/streamlit/requirements.txt

Ok so it looks like your requirements.txt is giving a lot of constraints, while maybe your app doesn’t need so many things? From the Cloud logs, it looks like some packages failed to install, notably tulipy.

What I’d recommend, if your app is only using that app.py, is to update requirements.txt so it really reflects what your app needs. Essentially, looking at your imports

import streamlit as st
import pandas as pd
import datetime as dt
from datetime import timedelta
from datetime import datetime
import plotly.graph_objects as go
from annotated_text import annotated_text

Probably these are sufficient in the requirements.txt:

streamlit
pandas
plotly
st-annotated-text

Let me know how that goes!

Hi, @arnaud.

thanks for the tips!

I just do this.

But the problem continues.

Do you mind sharing the logs you get?

You can see them by clicking on the in the bottom right corner black button

Of course!

Link to doc: https://raw.githubusercontent.com/bruninhanic/logsApp/main/logAppMercado27set2022_13h

Hey @bruninhanic, looks like your app is now live?

Did you change anything?

Thanks,

Hi, @arnaud!

I did nothing!

When I try access today, it worked, with a path problem.

I changed the paths a few times, and so I went back to the original and it worked.

=D

1 Like

:mage: I bet simplifying the requirements was the original solution!

Thanks for everything, @arnaud!

1 Like


does anyone know the answer for this also as i have been trying to rectify this problem.