After creating packages.txt app won't launch

I’m trying to install libreoffice so I can convert office files to pdf, but if I create a packages.txt with it, it’ll reboot the VM, then stick at “Please wait…”. I tried to clean the file, still the same error, been trying for the last 2 hours and nothing.
If I delete the file and refresh the page, everything will work fine. When the packages.txt is at my repo, seems like the whole VM is frozen, I click to reboot and it does nothing.

It’s not a python, but linux package. The docs says:
2. (optional) Add a packages.txt file to manage any external dependencies (i.e Linux dependencies outside Python environment). App dependencies - Streamlit Docs
Was it updated and now requirements can install both linux and python dependencies?

Hi @MarlonUpSide,

Can you share the link to the app?

Caroline

Sure, here it is.
https://marlonupside-propostaupside-gera-proposta-2fd18k.streamlitapp.com/

Hi @MarlonUpSide :wave:

I’ve confirmed with engineering that this is indeed a bug that will only affect users who have dependencies installed via apt / packages.txt. We’re working on a fix.

I will update this thread when a fix has been released.

1 Like

The fix has been released! :balloon: The solution is to delete your app on Streamlit Cloud and re-deploy it.