App having issues loading the st_aggrid.agGrid component after being deployed on GCP

I am getting a component loading error with agGrid (attached screenshot) when using my app deployed on GCP. It doesn’t happen when I run the app on my local machine. I have tried increasing the memory allocation on GCP, adding couple of seconds of sleep time before and after displaying the df like this AgGrid(DataFrame,gridOptions,height=825). I also tried upgrading the versions. I am using streamlit==1.12.0 and streamlit-aggrid==0.3.2. But nothing seems to work.

Any idea how I can fix this issue?

Thanks,
Rexon

Hi @rexon1992,

Thanks for posting!

This error message shows when it takes a long time to load the component – the message should go away once the component has loaded. Is it possible there’s an error preventing the component from loading? Can you share the logs for the app?

Caroline :balloon:

1 Like

Hi Caroline,

Here is are the logs from the web browser.

And this is from GCP Cloud Run service for the app

It only happen when data is displayed using Aggrid. I am guessing it’s an Aggrid api connection issue?

Thanks,
Rexon