App stuck at loading - Please wait

It works fine locally with streamlit v1.18.1. I just rebooted the app in Streamlit Cloud, now it is stuck at ‘Please wait’

Could you try clearing Streamlit related cookies and signing back in? Also what browser are you using? On Chrome, I don’t see the ‘Please wait’ message. I see the error/exception I’ve shared above. Do you see “Please wait” even when viewing the app in incognito?


I got the same problem with my Apps, doesnt load just show Please wait…
I guess streamlit servers are down, beacause this probelm occurs also with the streamlit apps from the offical examples by streamlit

i got the same problem tooo

Similar problem. Some of my apps work, some don’t.

This is not your apps’ problem. It seems the server is dead. If you check streamlit documenations you see also the apps created by them to educate people, are showing “Please wait”

Hi all :wave:

@Sinakian @kenndanielso @Yonatan_Adisaputro_H @saibot90 @giswqs are you all still experiencing this issue? Or has it been resolved? If you’re still running into it, could those of you affected please share a link to a relevant app, what browser you’re using, and potentially a screenshot of the app in this error state?

It is no longer stuck at loading, but I got the StreamlitAPIException(f"No such component directory: '{abspath}'"). Did the new streamlit release change the component api? The app was working fine previously.


@snehankekre Thanks my apps work again.

the problem now occurs again

It was working again. Now it stucked again. Sometimes it works sometimes no!
It was working without any problem until last month. Then every now and then it stucks.

Yep, same. It’ll work one day and then it’ll go down again like today. What’s happening?

I got the similar problem, the streamlit app in my local server is working well, but when i deployed it on k8s, i met this problem. the web display “please wait…” and seems it stucked at health check, anybody met this?

i use the streamlit official command

appreciate any help!!!

I am also facing same issue. I developed a web app using Streamlit, and it runs on my localhost. However, after deploying it on Google App Engine, it consistently shows a “please wait” message on the screen. I am using python 3.8 and Streamlit version 1.24.

For the testing I just deployed three files:

     import streamlit as st

     st.header("Header section")
  1. app.yaml
    runtime: python38

    entrypoint: streamlit run --server.port 8080
  1. requirements.txt

I tried both of the solutions mentioned here : App is not loading when running remotely - Streamlit Docs. But it didn’t work.

I also tried changing the version of Python and Streamlit and changing the server port but no luck.

Have you been able to resolve the issue?

Hey @sprasai,

I think the issue you’re seeing may be distinct from what’s documented in this thread, since you’re deploying using Google App Engine, while this thread is focused on deploying with Streamlit Community Cloud

Hey @Caroline ,

You are right. I had to use Google App engine Flexible environment rather than Standard environment since Streamlit supports python version >=3.8.

1 Like

Good to know! Were you able to get it working with the flexible environment?

Yes. Here is my configuration file:

runtime: python
env: flex

entrypoint: streamlit run --server.port 8080 

    operating_system: "ubuntu18"
    runtime_version: "3.8"

Awesome! I appreciate you sharing this – it will help future users if they get stuck!

1 Like