DownloadError: Postprocessing: ffprobe and ffmpeg not found on Streamlit Cloud


I’m trying to deploy my app on Streamlit Cloud, but I’m encountering an issue related to ffmpeg and ffprobe. My app works perfectly on my local machine, where ffmpeg is installed and accessible. However, when I try to deploy it on Streamlit Cloud, I get the following error:

DownloadError: ERROR: Postprocessing: ffprobe and ffmpeg not found. Please install or provide the path using --ffmpeg-location

I tried to add ffmpeg as a dependency in a packages.txt file in my repository, as suggested in Problems with ffmpeg:


However, this hasn’t resolved the issue, and I’m still getting the same error. Could you please provide some guidance on how to properly include ffmpeg and ffprobe in my Streamlit Cloud environment?

Thank you in advance for your help!

My repo link: GitHub - ahmad-alismail/Podcast_Analyzer

It looks like the problem lies here in the configuration of the yt_dlp package.

The path to ffmpeg specified there looks like something that would work with a custom ffmpeg build on a windows machine but Streamlit Cloud is a Debian machine. To use the ffmpeg binary installed from the packages.txt, you can set that path to:

See it working (at least up to the audio downloading part) here:

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.