Email passwordless login is not working


I go to the login screen to use my email to login to my account. It sends me the email with the “Sign in to Streamlit” link. After clicking the link, I get the following message:

{“message”:“The token ‘f9mOxGoM2z4R1npvYTbgKXiRJ’ has expired or is invalid.”,“errors”:[{“field”:“token”,“code”:“token_invalid”}]}

Steps to reproduce

This is not related to code.

### Additional information

![Screen Shot 2023-05-04 at 10.29.11 PM|690x205](upload://6UDpTBAkqf3HpnDicxcCQ9PhG41.png)

Hey @WilsonCampbell-BMOC,

Thanks for sharing this question! How soon after receiving the email are you clicking the link?

I have the same error. In my case, I clicked on the link within 30 seconds of receiving it.

I’m having the same issue. and I click the email link in less than 60 seconds.

Same here. Can no longer sign into streamlit cloud because of this error

Hello, we have the same issue. It looks like it works maybe for every second person in our company. Its pretty big issue to use app when people cant access. We tried it on VPN, many browsers,resends.
Please let us at least know that someone is working on it.

Same exact issue here. Any word on this?!

Hi everyone,

Our team is aware of the issue and working to address it. I’ll share more on this thread as I get more info.


Hello, We’re also experiencing this issue - are there any updates or an expected timeline on this?

Hey @ioanaSystemiq,

Our team is currently working on a fix for this issue (we’re hoping it will be resolved within the next week). In the meantime, I’d recommend logging with Gmail/Gsuite as a workaround.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.