File_uploader filesize

Hi, I’m having some trouble loading a textfile with the fileuploader method. When I reduce the amount of data in the file it works fine. So unless i remove something from the content of the file that is causing issues (seems unlikely?), it might be caused by the filesize (102 mb). The errormessage seems to be “405: Method Not Allowed”. Changeing filename does not alter the result. Is there a known limit to the size of the file being uploaded?

Hi @Tobe, welcome to the Streamlit community!

The first thing to check is whether you have the latest version of Streamlit (0.62.1). A few releases ago, we moved the file upload limit from 100MB to 200MB by default. If you want to upload larger files, you can, you just need to increase the max limit in a config.toml file:

# Max size, in megabytes, for files uploaded with the file_uploader.
# Default: 200
maxUploadSize = 200

https://docs.streamlit.io/en/stable/cli.html#view-all-config-options

1 Like

Thanks a lot @randyzwitch. Seems like I have an older version 0.61.0.

1 Like