I'am not able to Record a screencast

I’am not able to Record Screencast, nothing pop up when I click in the start button.
My web navigator is Google chrome and I run under unbutu server 18.04.4 LTS.
I try to record under Microsoft Edge, but this is the same behavior observed.

Python 3.7.5


1 Like

Hi there, I have the same issue (nothing happens when I click on Start recording!), with streamlit==0.60.0, with either Chrome or Firefox (dev), running from either a distant CentOS machine or a “local” WSL on Windows 10.


Thanks for reporting @annemariet (and @NotAfk). Let me find one of our engineers familiar with how this functionality works to see if they have any ideas.


1 Like

Are you guys getting any error in your browser console?

Which browser version are you running?

Hi, indeed, I can see a bunch of css & js load error like

DevTools failed to load SourceMap: Could not load content for HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

(this is Google Chrome over windows, Version 83.0.4103.61 (Official Build) (64-bit)) and the server is launched from WSL.

and also at the beginning:
The difference of maxandminmust be divisible bystep``

OK, sorry these were warnings that showed before I started the screencast. Here’s the error I get:

main.0143e221.chunk.js:1 Uncaught (in promise) TypeError: Cannot read property 'getDisplayMedia' of undefined
at e.<anonymous> (main.0143e221.chunk.js:1)
at u (10.5e94d18a.chunk.js:1)
at Generator._invoke (10.5e94d18a.chunk.js:1)
at Generator.e.<computed> [as next] (10.5e94d18a.chunk.js:1)
at r (10.5e94d18a.chunk.js:1)
at s (10.5e94d18a.chunk.js:1)
at 10.5e94d18a.chunk.js:1
at new Promise (<anonymous>)
at e.<anonymous> (10.5e94d18a.chunk.js:1)
at e.<anonymous> (main.0143e221.chunk.js:1)

I created a bug for this: https://github.com/streamlit/streamlit/issues/1523, so you can check the status.

Thanks for the debugging information !


Google chrome, and same behavior in Microsoft Edge. I don’t think it’s related to the webbrowser

The log that is posted above shows that there’s no getDisplayMedia method. I don’t know if you are getting the same error, do you have any trace for checking it ? @NotAfk

Please check your privacy settings as well