Refresh does not update app on 1.23.0 and above


Refreshing does not update the app on 1.23.0 and above. It was working fine on 1.22.0 and below.

I am deploying a Streamlit app in Kubernetes with the source file on a mounted NFS share. When I update the source file from another client with the mounted NFS share, the file updates on disk, but refreshing the app does not update the content. However, if I update the file directly from the app server, the content is updated.

I’ve tried 1.23.0 to 1.26.0 with no luck. Downgrading to 1.22.0 fixes the issue. I am using default Streamlit configurations.

Were there changes to how Streamlit watches files for changes that may have broken this behavior?

Steps to reproduce

Code snippet:

import streamlit as st

If applicable, please provide the steps we should take to reproduce the error or specified behavior.

  1. Deploy streamlit app
  2. Change source file
  3. Refresh

Expected behavior:
The app should reflect the changes.

Actual behavior:
The app does not update. There are no errors.

Debug info

  • Streamlit version: 1.23.0 to 1.26.0
  • Python version: 3.8

Thanks for raising this issue. I had noticed the same thing myself and hadn’t had a chance to sit down and find the specific conditions. I’ve raised the issue with the Community Cloud team and will take a further look at this myself when I get I chance. I’ll update this thread if I hear anything. Oops, this wasn’t for Community Cloud, but it could be there is some underlying issue that connects the two, so I’ll still take a look. :slight_smile:

Have you tried this approach on this similar post?

I have. It did not work.