Streamlit app not updating when github Repositories are updated

When i update my repository, commit to main and push to origin, my streamlit app does not update. It stopped doing that today. Since that i have tried to create a new repository and also created the app from scratch.

When i reboot the app it is updated. It all stopped when i by accident clicked a button at the top of the streamlit app which has something to do with the rerun of the app.

I experience the same with all my apps

Hey @Seamus1992,

Edit: Community Cloud is currently having an issue with this; it’s being investigated by our engineering team and we’ll update this page when we have a fix!


Ah thanks, I just got started on streamlit and was thinking why this is not a feature already.

Update – this issue is now resolved. Please let us know if you’re continuing to see this issue. Thanks!

Hi @Caroline ! I’m noticing I’m having this same issue only as of a few days ago. I’ve had a few apps for months now and they’ve been fine, and it’s only happened recently with the most recent app I’ve made. I’ve tried creating a new repo and new app (both) and it hasn’t fixed it. The only thing that works so far has been rebooting the app completely, and only then do I see the changes. Any help would be appreciated!

Hey @kmaurinjones, have you tried temporarily disconnecting your Community Cloud account from your GitHub account (via the “Settings” menu in the top right corner) and then reconnecting the two?

I have not, but I’ll do so now. For any specific amount of time, or just disconnect for a moment and them reconnect it?

Just for a moment, so we can rule out any issues with your Community Cloud account’s connection to your GitHub account

I’ve tried it and it still doesn’t seem to be updating the app automatically with new commits, even after a few minutes

@Caroline Actually, it seems to be working now! Not sure what changed, but it looks good. Thanks for the help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.