RROR: No matching distribution found for dataclasses==0.8

Hello any help is appreciated. Sentiment analysis using BERT and streamlit
Is there away to get pass this error? The error happens when deploying on Streamlit.
The module dataclasses==0.8 requires 3.6. I don’t see any other dependencies missing. I have this working in a docker file. However, I really would like to see this work on Streamlit.

Downloading cycler-0.10.0-py2.py3-none-any.whl (6.5 kB)
Collecting Cython==0.29.22
Downloading Cython-0.29.22-cp37-cp37m-manylinux1_x86_64.whl (2.0 MB)
ERROR: Could not find a version that satisfies the requirement dataclasses==0.8
ERROR: No matching distribution found for dataclasses==0.8
[manager] Python dependencies were installed from requirements.txt using pip.
[manager] Processed dependencies!
2021-04-08 01:34:32.637 An update to the [server] config option section was detected. To have these changes be reflected, please restart streamlit.
2021-04-08 01:34:32.714 Uncaught app exception

Hi @devcode925,

Don’t have access (yet) to streamlit sharing, so can’t repoduce the error.
Seems strange though that this fails since the dataclasses package is pure python and should work on any platform.

You could try the following:

  • Check the spelling and versioning in requirements.txt
  • Unpin the version, since the latest version is 0.8
  • Install straight from source. So add git+git://github.com/ericvsmith/dataclasses@0.8#dataclasses in requirements.txt

hope this helps a bit

Hi Maarten, thanks for reply. And thanks for the ideas. I will try them out. I do have this app running in a docker image on GCP, but is a image made for ML.
I do like how easy Streamlit handles the display. I am hoping to seeing it running soon on Streamlit.

As of Python 3.7, this is no longer necessary and will therefore go wrong during deployment.
dataclasses is part of the standard library since 3.7, so remove it from your requirements.txt.
Streamlit sharing currently runs with Python 3.7.10


Thank Franky1, I did that, and got passed it however, there are other modules that needed changing. Which I either removed the version or >= my version. I do have this running on 3.6.
The current error is below. Thanks for your help.
Then got to ```
Requirement already satisfied: pyrsistent==0.17.3 in /home/appuser/venv/lib/python3.7/site-packages (from -r requirements.txt (line 111)) (0.17.3)
ERROR: Could not find a version that satisfies the requirement python-apt==1.6.5+ubuntu0.5


I would save myself these problems and also work locally with Python 3.7.x.

This is not a valid package in the pypi repository, therefore cannot be found.
Maybe you installed the python-apt package manually on your local machine?
And besides, afaik python-apt is outdated as well.

I would update your Dockerfile.

If you want, you can share the link to your public github repo, then I think we can move forward faster. :wink: