Server error [A15]: Error creating workspace What does this mean?

Great. I’ve let the Devs know.
Hopefully, it shouldn’t be too long for that switch to happen.
I’ll let you know when done :slight_smile:

Best,
Charly

Hi,

I just got my application approved for access to the Streamlit Cloud. When I tried to deploy my first app, I was facing this “Error creating workspace” issue. I thought it was due to the code implementation of my Streamlit app. However, when I was trying to deploy the sample template, this issue persists.

Is anyone facing the same problem?

Hi,

I’ve changed the name of a Github organization I own, and now I have this same problem. Is there a way now to fix it? Thanks

Hi @Charly_Wargnier, same problem for me here. I changed my GitHub username and now I’m not able to deploy anything.

old username: koti
new username: menkotoglou

Hey @Charly_Wargnier, having the same issues here as well.

  • Old Github username: squaddaffi
  • New Github username: parkerik

Hi @Charly_Wargnier ! Is it still possible to have my account details modified in the db as well? Just got back to trying streamlit again but am still getting the same errors. Please let me know if there are other workarounds to this as well.

Old Github Username: chipsaint
New Github Username: chisantos

Thanks!

Hi @Charly_Wargnier, same issues here.

  • Old GitHub username: nehtr
  • New GitHub username: voidpunk

Thanks!

Hi @alberduris @menkotoglou @Squaddaffi @chisantos @voidpunk

Thanks for your feedback.

I will nudge the Devs and see if we can get a DB update where relevant.

We will come back to you shortly. Thanks for your patience!

Best wishes,
Charly

Hi @alberduris

We may need to make a DB change for you.

Do you have your old and new usernames please?

Thanks
Charly

Hi @coderdoufu

Are you still facing the same issue?

Thanks
Charly

Hi @alberduris @menkotoglou @Squaddaffi @chisantos @voidpunk

We updated the DB details. Thanks for your patience. :pray:

Would you mind checking that things are working correctly on your end?

Thanks,
Charly

@Charly_Wargnier thank you for the quick response, I just tried and unfortunately it gives the same error

Hi @monchier

Apparently this is still an issue for @voidpunk. Do you know what may be going wrong here?

Thanks,
Charly

@Charly_Wargnier
Good evening, I was trying to deploy a streamlit app when the same error occurred to me.
Old username: lamb-does-code
New: alessandrolamberti

Is it possible to change it in the DB?

@Charly_Wargnier still not working… (same error)