Server error [A8]: Unable to create app

I am using streamlit sharing. I can not create new app. The error message is Server error [A8]: Unable to create app.
Please help!

Hi @Steve_Chen -

Can you give us some more information? When did this start happening, what repo are you trying to deploy…

TC Rick is helping me now!

Both won’t work! (These worked properly before. But due to the following error, I deleted them, but wasn’t able to redeploy them.

Streamlit error: Argh.
This app has gone over its resource limits. Common causes for this are memory leaks in the app logic, using caching without a TTL, or leaving large datasets in memory even after they are no longer needed. Please update and reboot this app to try again.

It happened three days ago!

the slash (/) in the main file path looks so suspicious, so I got rid of the slash (/), IT WORKS!

This is what I have done: change / to



1 Like

I was having the same issue and Steve’s solution worked for me! I was having the same A8 error.

If you remove the ‘/’ from the line where you provide the Main file path, it should deploy correctly!

1 Like

Thanks for confirming @Aren_Carpenter and @Steve_Chen! I’ll send that to our product team, it should be a pretty simple test to see if there is a leading slash at the beginning