Streamlit App doesnt show new code after code push to GitHub

Hello all,

I am currently having troubles with the streamlit community cloud. I have two pages which are attached to the same GitHub repository but different branches.
When I upload new code to the Repository and then reboot the app, it doesn’t show the new code. On GitHub, I can see that the webhook delivered a push with the correct commits. Yesterday (08.22.2023) everything worked. After rebooting, the code showed up.
The code is deployed with Python 3.9.

Can anybody help what the problem might be? And I am uncertain if this topic already exists. One existed already but was closed due to inactivity.

Kind regards,

Streamlit deploys from a single branch, it won’t check the other branches of the other repo. When deploying, you get the option of which branch to dploy from. If you deploy your app from main branch but then push new commit to dev branch, it won’t show up on the deployed app on streamlit cloud.

You can deploy multiple versions of the same app each from a different branch within the same GitHub repo.


Thanks for your swift answer!

Actually, I did this already. I use two different branches for my two pages. One is page is with the main branch, one is with the develop branch. But when I push new code to the develop branch, the site corresponding to it won’t refresh. Even after a reboot.

This is confusing, what do you mean by “pages”?

Do you mean “apps” since it’s the whole thing that’s “deployed” on streamlit cloud, it’s a whole standalone app.

A “page” is just another file in the same app in the same branch (,,
If a new branch is created the whole app is duplicated with it’s app file & pages.

So pelase be more precise as I find it difficult to define and understand the subject.

I’m observing similar behavior where the app doesn’t successfully reboot and doesn’t display the latest changes. When I try rebooting apps, I see the logs stuck at Spinning up manager process...

Is it the same on your end? If so, I’ll alert the Community Cloud team about a possible issue with rebooting apps.

Dear snehankekre,

Thank you very much for your prompt response. Yes, it is exactly like that on my end.

1 Like

Dear IndigoWizard,

I am so sorry that I am unclear.

By pages, I ment different deployed streamlit apps. I got used to saying pages and not app. I am sorry.

What I wanted to say is that I have a streamlit app for the main branch, and a different one for the develop-branch. When I push to the develop-branch, the corresponding app doesn’t display the new code.
Is this better now? Hope it helped you

Yes now it’s clear as the terminologies are technically different.

To clarify:
The gist of your issue is that you are in fact, deploying two separate apps. It just happens that they live in the same repo as different branches (welcome to the multiverse).

  • The main branch is not related whatsoever to the current issue.
  • The develop-branch is facing a deployment update issue

In this case, just as @snehankekre mentioned :

similar behavior where the app doesn’t successfully reboot and doesn’t display the latest changes. When I try rebooting apps, I see the logs stuck at Spinning up manager process...

So this can be solved by Streamlit Team with their servers. It means you may just have to wait that the servers issue is fixed.


If you absolutly need the update to go up now, you can create a new branch dev from your most updated one develop-branch and deploy it. Newly deployed apps are not facing this issue (as I just deployed a new app ~30mns ago).
Once the server issue is fixed you can dial back to the old develop-branch and delete the new dev-branch or keep it for further testing in the future.

1 Like

Thank you so much for your rapid response.
Very helpful! Of course from @snehankekre too!

Kind regards,

Restarting or resuming applications is not working on Community Cloud. The team has identified the issue and implemented a fix and we are monitoring the results.

Hey everyone, this issue is now resolved – please let us know if you continue to see this problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.