Streamlit not update after Git push to Github

My deployed Streamlit app does not updated once I git push new changes to Github. I need to reboot everytime I push to the Github to get the updated changes. This is so so counter productive.

How to solve this issue?

Hey @cheese_kut,

Have you tried disconnecting your Community Cloud account from your GitHub account and then reconnecting the two? Sounds like an issue with Community Cloud’s connection to your GitHub account so does this might resolve the problem

How to disconnecting and connecting back between both? The Streamlit app is basically deployed from my orgs repo, using my Github account.

Tried to log out my Github account and reconnect again. The app still don’t update the new changes as I pushed. @Caroline

To disconnect your GitHub account, you can click “Settings” and then “Disconnect”

@cheese_kut are you still encountering the issue? Can you try deleting and deploying the application again?

I have tried 5 times. Delete and redeploy. Changed the domain too. And it still not updated unless I reboot it.