Streamlit is Broken ! Streamlit MUST support Bokeh v3.0 ASAP

streamlit.errors.StreamlitAPIException: Streamlit only supports Bokeh version 2.4.3, but you have version 3.2.2 installed. Please run `pip install --force-reinstall --no-deps bokeh==2.4.3` to install the correct version.

Streamlit must update to Bokeh v3.x

I have a financial applications that REQUIRE Bokeh v3.x NOW.

Bokeh predates Streamlit by many years, and has provided interactive plotting long before Streamlit existed.

Come’on Streamlit … Support ALL mainstream FOSS packages (like Pandas, Matplotlib, Scikit-Learn, Plotly and others) !!!

Now I MUST switch to Flask or another rapid prototyping framework like PyGWalker until Streamlit gets its ducks in a row.

See ya later, Streamlit.

Hi @Richdev_Boston,

Here’s the answer from our PM team we recently gave on supporting bokeh > 3.0:

As Johannes says, please use GitHub Issue upvote to manifest your interest, and check out the workarounds in that thread too,

Have a good day!