Streamlit not detecting changes to multipage apps in WSL2

Hello,

I use WSL2 for all my development work. However, Streamlit isn’t detecting file changes in multi-page apps when I run it in WSL2.

I noticed that while it DOES detect changes to the main page, e.g. Home.py, it isn’t detecting changes to nested pages (e.g. a page in the pages directory), nor is it detecting changes to python modules that exist in the same parent directory (I confirmed that my python path includes the parent directory).

I created a minimal example here. I ran it both in Windows (where changes to all pages and module were detected successfully) and in WSL2 (where changes to only Home.py were detected).

Other information:

  • Streamlit v1.11.0
  • Windows 10
  • WSL2 (running Ubuntu 20.04)

Let me know if you need any other information!

Hi @jonstrutz11 :wave:

Would you mind submitting a Bug Report on Streamlit’s GitHub repo? That should bring the issue to the attention of our devs and community.

Best, :balloon:
Snehan

1 Like

No problem! See here