Streamlit sharing not working

Hi, I have deployed my app via Streamlit sharing with the options:

  1. “Only specific people can view this app”
  2. And, 3 email address under “Invite viewers by email” in the “Sharing” section.

My App: https://kristalretriever.streamlit.app
My Github repo: GitHub - yashmehtakristal/KristalGPT-noauthentication: Kristal GPT Version (No Authentication)

The issue here is that whenever a user goes to my app and then signs in via Google with their email address, they cannot access the app directly.

I’m getting this error when I’m looking at developer tools:

And, this error when I’m looking at network tab:

Attaching a video of the entire process, if it helps (Please look at timestamp 2:54 onwards):

Here’s what I have tried:
Using different browsers

  1. Using incognito mode
  2. Clearing cache and cookies
  3. Ensuring the email I’m using to logging into the app isn’t already logged in concurrently (should not affect, but just tried)
  4. Disabling any VPNs and ensuring I have internet connectivity at all times
  5. Trying on my other devices

I have also looked at other streamlit forums and stackoverflow but no one had this issue. I have also looked at streamlit configuration page and didn’t find any setting that might counter this unusual behavior.

Yesterday, I tried and after 30 seconds to 2 minutes of this refreshing & redirecting error, it loaded my app. So I thought maybe just need to wait out (for an arbitary amount of time). But today, I didn’t even get access to the app after 2 minutes mark, which is really annoying.

Note, this app works perfectly when deployed publicly and loads in 5-10 seconds. I’m guessing this is purely a streamlit issue.

I am really depressed. Would really appreciate any help from some kind soul please.

Thank you so much for reading this post.

Hi @Yash_Mehta,

Thank you for reporting this issue. I apologize for the inconvenience.

Are you getting the following error?

If so, please contact our dedicated support team through the link on the error page.

I’ve also looped in @Ayo , as he may be able to provide more feedback on this specific issue.

Best wishes,
Charly

1 Like

Hey, thank you so much for your reply. No, I’m not getting a huh page, just a spinner that keeps reloading.

I’ve sent an email to streamlit support email. @Ayo thanks for helping in advance

Hi Yash! I’ll be looking into this issue today. It might be related to a new system that I am building that should improve page loading time. Could you provide a HAR recording via DM? Generating a HAR file for troubleshooting – Zendesk help

Thank you very much for raising this!

1 Like

@Yash_Mehta I see that you could see the application on the 7th of November. It seems that the cache holding your permissions was out of date. We’re working on fixing this.

Can you confirm whether you are able to view the app?

1 Like

Apologies for the late response. The thing is it keeps refreshing for an arbitary amount of time (sometimes 1 minute, sometimes 5 minutes) before letting me in the application.

Here, Streamlit deployment showing error · Issue #7684 · streamlit/streamlit · GitHub, Maya is saying there is some stale cache on my side, but I think this is a streamlit deployment error.

I say this because I tried on 3 different incognito browsers. Please help assist, thanks!