Tunnel Not Found while working on google colab

I am getting this error

Tunnel 8ce0b041d49d.ngrok.io not found

after running the app in google colab using ngrok

please help me resolving this issue

Facing same issue. evrything was working fine till 2 three days back. I was using ngrok version 4.1.1. Suddenly tunnel not found error started coming while deploying the streamlit UI. som1 please help

I also face the same problem, The links that generated by ngrok worked fine for two days. then every link it generated when follows i found " Tunnel xxxxxxx.ngrok.io not found". Please any one can provide any explanation for that.

Same problem facing from last 2 days. :disappointed:

I also face the same problem

I also have a project.
I’ll deliver it tomorrow, and I used ngrok too.
Please help.

1 Like

Hi guys found a neat quick alternative in local tunnel. code is of two lines you can check out below link. works with streamlit. Can use it till ngrok gets sorted


Hi everyone, specially @Kareem_Negm, I don’t know the solution to this issue, and have tested several options but didn’t work. So I assume that this is related to Colab, and instead used the Jupyter Notebooks in Kaggle, and it works as expected.

So, my advice is to try working with the Notebooks in Kaggle, at least until a better solution is found!

Here is what I did, hope it helps!!

1 Like

Btw, here is the link to Jupiter Notebook in Kaggle

1 Like

Thanks a lot Mr. @napoles3d

1 Like

Hi Mr. @napoles3d. I have a similar problem. I had developed a web application (using streamlit and ngrok) using a model I previously trained on Google colab. It used to work before, but now I’m getting the tunel not found error. I tried using a kaggle notebook as you suggested, but my codes do not work. While working on Colab, I could get the model from the driver with the tf.keras.load_model method, now how can I do this? It also doesn’t work in the libraries I’m trying to include. Please help me.

Hi @Busra_Duygu
Please check the internet option in settings of kaggle notebook. Turn it on if it is off


Hey @Busra_Duygu do you have the project on github?? can you share to see a litle more?
I think that Colab has some conflict with ngrok now, as there are many recent post on the internet not only related to streamlit, but in general to the use of ngrok with Colab, and not sure when this is going to be fixed.
However, I assume that if you can run a Jupyter Notebook on any cloud service, you would be able to use ngrok to run streamlit, for example the service of Kaggle, and I think that others like microsoft’s Azure could work too.
So, if Kaggle doesn’t work for you, something easy to do could be trying in Azure for example. But you have to be careful of installing any library needed. Not sure if these services have as many as Colab does.
Hope this helps :upside_down_face:


Anyone of you want to try this??

1 Like

Thank you so much :sob:, I read the comments on the link turns out it works. I will try this out for myself too. Was going crazy today looking for a way… Lifesaverr

1 Like

Happy to hear that!!

1 Like

Thank you very much for your reply, Mr. @napoles3d.:slight_smile: I don’t have an github account, but I can create an account and share the codes so you can see it. Can I upload a dataset from anaconda / spyder and train with this dataset and then use this trained model in a web application?

I tried it and it worked thank you very much :slight_smile: :slight_smile:

1 Like

pyngrok working fine again in collab. they fixed it from ngrok side. For more info check this out