Webrtc component examples are not working in streamlit anymore?

I tried to use https://share.streamlit.io/whitphx/streamlit-webrtc-example/main/app.py , but it does not work even on the official examples. Tried on different devices and browsers, are there any updates on that? Could not find anything

1 Like

Hi @divintajee, and welcome to our forums! :hugs:

It doesn’t seem to work on my machine either. I’m looping in @whitphx (who created this component) in case he can help diagnose the issue here.


@poloniki Have you tried making this app on localhost ( your local machine)?

1 Like

Yes, tried it locally, did not work. Sometimes random frame appears, but then stops working again, unfortunately.

@poloniki Thank you for reporting this!
I rebooted the app and it may help. Can you please try it again?

I think it was because the WebRTC server config was cached and outdated. I also deployed the fix so hope it won’t happen again.

1 Like

That’s great! Thanks @whitphx! :hugs:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.