My app is taking too long to deploy

Hello everyone, first time post here.
Please I’m trying to deploy my app on streamlit’s share but it keeps on just showing “Your app is in the oven” and just remains there. Meanwhile it works perfectly on my local computer.

here is the github repo: GitHub - Bwhiz/my_plotter_app: A simple graphing app for experimental physics results equipped also with a 2D/3D function plotter.
here is the supposed app link: .
Please help

Good day all.
Its up and running now, I simply delisted “streamlit” from the list of dependencies in my requirements.txt file and it worked.
keeping this post incase anyone in future has similar issues.

But can someone please explain why this is so, was it actually because “streamlit” was listed in requirements.txt ?


@Bwhiz is right.

In addition, do not add windows specific libraries in the requirements.txt. Apparently, streamlit runs on Linux

In conclusion, long deployment means something is wrong in the requirements.txt.

Hi, I am facing this same issue and have tried both ways removing streamlit from requirements.txt file and the other way around but still facing the same issue

Any Suggestions?

Hello, all I did to solve this issue was Reboot the app via the “Manage App” settings