Please help! Error due to update of "cffi packages" deploying my app that previously was generated

Strangely until yesterday my application was deploying normally. I have just checked the dependency indicated in the error and it mentions that I have to install the latest version. This is already included in the requirements.txt file. Please help me with this problem that is generating conflict with my other dependencies.Thank you very much for your help.

image

1 Like

I am getting the same error.

I was getting it yesterday and today. I assume we need a package update on the shared server.
However, my app is on 3.9 and other package conflicting issues. I did not have Streamlit in the requirements do so it was auto installing after the requirements.

I solved it, for me.

Streamlit auto removes a bunch of (useful) packages at the end of the installation.

So it needs to go first in the requirements doc.

Here is snippet of it uninstalling all sorts, including pandas!.

Getting the same error. Tried putting streamlit as the first package in the requirements.txt but still getting the same error.

I had the same issue and found a workaround. The mismatch was between cffi 1.15.1 and 1.15.0

First, downgrade cffi:
sudo pip install --upgrade cffi==1.15.0

Then in requirements.txt make sure to have the first entry as:
streamlit==1.10.0

and include anywhere else in requirements.txt:
cffi==1.15.0

now the deployment works for me.