Unable to deploy multipage app

EDIT: Streamlit cloud is still refreshing and not deploying despite having selected the correct file.

Hi everyone! I’m having an issue deploying my multipage app on the streamlit cloud.

I have the main page (Welcome.py) in my root folder and the other pages in the pages folder.
When prompted to select the main file path, I am unable to select Welcome.py.

I tried selecting one of the option but the page just kept refreshing.

Hi @joannakhek, welcome to the community! :partying_face:

You should see Welcome.py if you scroll to the bottom of the “Main file path” dropdown menu:


Best, :balloon:

Hi @snehankekre,

Thank you for the quick reply!

I have tried selecting Welcome.py but the page is still refreshing like the gif above.
Any idea why?

Could you try deleting the app on Cloud and re-deploying Welcome.py? Let us know if that helps.

Unfortunately, deleting the app and re-deploying it doesn’t seem to help as I’m still having the same issue.

From the gif you’ve shared, and the URL in it, it looks like you’ve deployed the pages/2_Overview.py file instead of Welcome.py :thinking: Regardless, the page refreshes shouldn’t be happening. I’ll relay this issue to the team.

In the interim, I would suggest creating another repo with the same content and deploying from the new repo. I was able to deploy Welcome.py from a fork of yours.

The refreshing issue was exactly the same so I did not update the gif.
This is the updated gif using Welcome.py


1 Like

I tried creating another repo with just the Welcome.py script but ran into the same issue. Not sure why this happening :cold_sweat:

Hi @joannakhek :wave:

Thanks for your patience. The redirect loop can happen due to mismatched sessions / cookies. Could you try signing out from share.streamlit.io and sign in again and see if that helps?

Hi @snehankekre! After signing out, it worked!!!
Thank you so much for your help!

1 Like

@snehankekre hello there i am facing the same issue, i have made a multi-page application in which i have created it using Create a multipage app - Streamlit Docs

The main issue i am facing is while deploying the multi-page application i have uploaded all the necessary stuff needed on github and linked the repository. Now when the application is deployed i am unable to see any of the pages on the side bar. Please help me in getting this. I am using share.streamlit.io for deploying it

Hi @ritik27-santosh11 :wave:

Welcome to the Streamlit forum! Please take a moment to read through our guidelines on how to post an effective question on the forum and, in particular, please share the link to your public Streamlit Cloud app, GitHub repo, and the specific error message you’re seeing.

Here is the Github repo link :- https://github.com/ritik27-santosh11/New-new-one

Streamlit cloud app :- https://ritik27-santosh11-new-new-one-1--home-ji351d.streamlitapp.com/

I am not experiencing any of the message but the main issues is that i have made a streamlit multi-page app by creating folder within another folder as specified in this streamlit docs: - Create a multipage app - Streamlit Docs

But after deployment there is no content on the sidebar where as if i run the application on the local host in streamlit there is showing a sidebar with multiple pages option

But no side bar showing pages option after deployment

Unfortunately, the repo is private. There’s no way for us to review the code for bugs if it’s behind a private repo.

https://github.com/ritik27-santosh11/New-new-one here is updated one sir sorry for that

@ritik27-santosh11 Your app’s pages should live in a pages directory or folder. It looks like you’ve capitalized it to Pages instead.

Once you rename the Pages folder in GitHub to pages and either reboot your app or delete the app on Cloud and redeploy it, the pages should show up in the MPA sidebar :smile:

okay looking forward to sir

Thank you sooo much sir for your time, i can’t tell you how happy i am you saved my dream project. Cheers to streamlit and team :smiling_face_with_three_hearts:

1 Like